PnP TerrainCreator - Forum

The PnP TerrainCreator Forum
It is currently Sat Nov 18, 2017 7:41 pm

All times are UTC




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 
Author Message
 Post subject: Problem with SDK and Beta version 1.1.7.3
PostPosted: Wed Jul 27, 2005 1:32 pm 
Offline

Joined: Thu Apr 07, 2005 12:57 am
Posts: 70
Location: Lake Wylie, SC
After I downloaded the 1.1.7.3 beta, my custom exporter crashes. I determined that any calls to the App object (CIPnPTCApplication01) cause an error...or at least the calls I was making (to access the progress bar). I remarked out my calls to the App object and it seems to work now.. I just can't see a visual on the progress now :lol:


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 27, 2005 1:42 pm 
Offline
Programmierdochfix
User avatar

Joined: Tue Apr 27, 2004 12:53 pm
Posts: 892
Location: Braunschweig
Yes, that is a general problem. As long as I'm extending the interface that will happen from time to time.

The reason:
I added a new method to the App interface. An this causes the methods to be in a different order within the binary (simply speaken). Your "old" PlugIn thinks it calls the method "SetProgressBar" but within the binary it calls, lets say, "IncrementProgressBar". Different parameters... stack corruption... crash.

The solution:
You don't have to mark the progress bar commands out. Simply rebuild your PlugIn and everything should work as before.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 27, 2005 2:08 pm 
Offline
Programmierdochfix
User avatar

Joined: Tue Apr 27, 2004 12:53 pm
Posts: 892
Location: Braunschweig
Uuuups.

You don't have the new includes, that's a problem :oops:

I'll add a beta download for the new SDK in a few hours, so you can rebuild you PlugIn correctly.
Sorry


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 27, 2005 5:38 pm 
Offline
Programmierdochfix
User avatar

Joined: Tue Apr 27, 2004 12:53 pm
Posts: 892
Location: Braunschweig
OK, a beta download for the SDK is now available.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 27, 2005 10:27 pm 
Offline

Joined: Thu Apr 07, 2005 12:57 am
Posts: 70
Location: Lake Wylie, SC
Thanks :)

Yeah, I tried the rebuild before posting originally about the problem. I knew at that point that I probably needed new files. I later found out that even though other calls were not crashing my exporter, I don't think I was getting correct resutls. I will download the updated files and give it a try.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: