PnP TerrainCreator - Forum

The PnP TerrainCreator Forum
It is currently Sun Sep 24, 2017 7:13 pm

All times are UTC




Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 
Author Message
 Post subject: Access Violation in re-compiled plugins
PostPosted: Fri Apr 11, 2008 10:56 pm 
Offline

Joined: Thu Apr 07, 2005 12:57 am
Posts: 70
Location: Lake Wylie, SC
I recently got a new PC and attempted to recompile some custom plugins. Everything is fine until it attempts to get the texturemap object. This results in an Access Violation.

I ran the standard texture map exporter and exported a texture map from my test terrain with no problems.

Then I opened the project for the texture map exporter in the SDK samples and re-compiled it and ran it and got the same Access Violation. This occurs at this line of code.
Code:
CIPnPTCTextureMap01* pTexMap=(pTextures)?pTextures->GetTextureMap():NULL;


OS = Vista
MS VS 2005
DX SDK March 2008


Top
 Profile  
 
 Post subject:
PostPosted: Sat Apr 12, 2008 9:00 am 
Offline
Programmierdochfix
User avatar

Joined: Tue Apr 27, 2004 12:53 pm
Posts: 891
Location: Braunschweig
Are you sure that pTextures is initialized with NULL and does not hold any garbage pointer? Otherwise it sounds as if SDK and main program version do not match. Have you tried to compile the sample/standard plugins and tested if they still work after recompilation.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Apr 12, 2008 1:31 pm 
Offline

Joined: Thu Apr 07, 2005 12:57 am
Posts: 70
Location: Lake Wylie, SC
pTextures is initialized with valid texture pointers as far as I can tell. As mentioned in the first post, I did compile the standard texture map exporter and had the same problem occur. Could it be the version of the DX SDK possibly?


Top
 Profile  
 
 Post subject:
PostPosted: Sat Apr 12, 2008 3:45 pm 
Offline
Programmierdochfix
User avatar

Joined: Tue Apr 27, 2004 12:53 pm
Posts: 891
Location: Braunschweig
Well, I'm using the latest DX version which supported static linking of the d3dx libs. Which is DX9C december 2004. However, for that particular line of code, the DX version shouldn't matter, I think. Do have have a crash dump or call stack dump, which might help?


Top
 Profile  
 
 Post subject:
PostPosted: Sat Apr 12, 2008 8:43 pm 
Offline

Joined: Thu Apr 07, 2005 12:57 am
Posts: 70
Location: Lake Wylie, SC
It's quite possible that I have a mismatch between EXE version and SDK version. Since this is a new PC and a fresh install, maybe I got version mixup. It looks like this may be the issue.

[EDIT] This is most definatly the problem. Sorry for the confusion. I haven't tried the plugins with the correct version yet but I fully expect the problem to be resolved when I get the latest version of the app installed.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron